Forum Lobby

Possible to start on a tiny island?

Has anyone found a way to start a game on a tiny island? I want to play as a secluded tribe and try to survive with little.

My issue is the game won’t let me settle on any tiny islands because they’re too small to let me select them on the world map. Is it planned to make sure this is possible in the future? It would be really disappointing if there was no way to remedy this.

This is as close as I could get to an “Island”, just in case someone else wants the saved game:

20201013183836.zip

If someone wants to share where they’ve found a small area surrounded by as much water as possible that would be great.

1 Like

I tried loading your save but it failed. Maybe mod enabled? Curious what island you tried to settle on as I happen to live on one of them!

1 Like

@riclep oops! I’ll try again with no mods. That completely slipped my mind.

A temporary solution to the issue on this topic could be a mod that allows you to migrate over the water. This would at least get me where I want to go. But I don’t know how possible that would be with the current limited mod support.

Very easy only change Entity/Faction Medium to “Amphibious”.

1 Like

Yes! Thank you for this info!

Where on the map are you settling? I’m curious! :blush:

1 Like

Maybe this will work… If not I can always just show you a screenshot of the local region map 20201013183836.zip

The save didn’t load again. Not sure why, might be due to me poking around with the core files a little while ago.

If you’re trying to settle here on the island with the arrow pointing to it we have some great dolmens you might be interested in.
image

There’s a website about them here: http://www.megalithicguernsey.co.uk/ and my son researched them for school/the first couple of episodes our little podcast: https://thecuriosityofachild.com/

I definitely hope we can survive on islands long term as I want to recreate my home.

@UncasualGames I feel dumb now… After an hour or so of getting nowhere, this is the only relevant file that I could find:

C:\Program Files (x86)\Steam\steamapps\common\Ancient Cities\Ancient\Data\Ancient\Entity\Region\Human\Faction.art

This is the area in the file that I think you are talking about:

Entity/Faction:{
Name:“Entity”
State:“Enabled”
Speed:“5,7,14,1”
LocationDeep:"-0.001,0"
LocationSlope:“1”
UIOffset:“2.4”
UIDistanceRange:“0,90”
}

Searching how to properly edit/format .art files doesn’t get me anywhere. All I get are references to this:

Is the extension name irrelevant? Is there a name for the format used in all of the game’s .art files? Why am I such a noob at this?

@riclep It just isn’t my day… It also slipped my mind that one of the mods that I had enabled was the one to make the entire global map settleable. It was in the Bay of Bengal.

LocationMedium:“Amphibious”

1 Like

Art is the name of our in-house engine. This is not an standard format. We will add more info about this format in the MOD section of the forum.

1 Like

After doing this:

Entity/Faction:{
Name:"Entity"
State:"Enabled"
Speed:"5,7,14,1"
LocationDeep:"-0.001,0"
LocationSlope:"1"
UIOffset:"2.5"
UIDistanceRange:"0,90"
LocationMedium:“Amphibious”
}

This happens:

[22:03:52] Ancient Cities.Alpha.0.0.1.16.1
[22:03:52] Windows x64 64 bits
[22:03:52] CPU Hardware threads : 12
[22:03:52] GPU : NVIDIA Corporation GeForce GTX 1080/PCIe/SSE2
[22:03:52] Using Opengl v4.4.0 NVIDIA 441.66 GLSL Shaders 4.40 NVIDIA via Cg compiler
[22:03:55] ERROR - Node '/Ancient/Entity/Region/Human/Faction' failed to load File 'C:/Program Files (x86)/Steam/steamapps/common/Ancient Cities/Ancient/Data/Ancient/Entity/Region/Human/Faction/Faction.art'
[22:04:00] Shader cache : 2790 shaders will be pre-compiled
[22:05:20] ERROR - Loading saved game : Entity /Ancient/Entity/Region/Human/Faction/Entity does not exit.
[22:05:30] ERROR - Exception code 3221225477 - EXCEPTION_ACCESS_VIOLATION

Very easy? I guess I’m missing something… Maybe I’m not cut out for this. :man_shrugging:

Those quote symbols seem a bit different from our quote symbols.

Oh no… Look what 've done, right in front of the developers… That’s just embarrassing.

Nevermind, after fixing those quotes it still crashes with the same error when starting a new game.

I wonder if I’m still just doing something wrong or if it’s some kind of internal problem with the game that’s preventing the modification from being successful?

There is a related bug. We will fix it for the next update.

2 Likes

Alright, thank you! I really appreciate your effort to help me out. I’m glad if I helped find a bug.

1 Like

@riclep I’ve finally found an actual island that I could settle on due to buggy mechanics, or something! I’ve used the mod to make the entire global map settleable, but apparently you can still load the saved game without the mod at all.

20201027184124.zip (38.5 MB)

It’s still not ideal, as I’m interested in a baby island compared to this. I will just have to be patient.

LocationMedium:“Amphibious” Still does not work, maybe next time.

We have designed a way to allow to travel to tiny islands but we have many other high priority tasks to finish before that. Please be patient :slight_smile:

3 Likes