Forum Lobby

Closed Beta Not Working

I’ve entered the beta key I got and installed the game, but when I run it it just says “do you want to send a report to us?” and then stops playing in Steam no matter what I click. I’ve tried reinstalling the game and running as administrator but it hasn’t worked. Please help, I really want to play!

2 Likes

Same issue here. Running on Windows 10.

Probably your graphics hardware is unsupported, you can check Log.txt file in documents and settings game folder.

I had the same issue but it was my firewall software blocking it. Try making sure its not blocked by your antivirus security software.

Hi I have received email to say I have a reward, I’m guessing this is my key yet when I log in there is no key

1 Like

Hello Elfryc,
Your post helped find the mystery secret location. After clicking the EULA the screen disappears but nothing happens. I’ve tried several times. I’d say they ran out of keys but they say Lords get a key…? Any idea what the next step should be at accepting the the EULA?
Regards

1 Like

Hey @Maximus
Sorry, I was gone eating (and that’s never a good idea depriving a Frenchman of his cheese), then could not find this thread back, as this are a bit messy with the sudden influx of people in every part of the forum.

I guess by now you’ve seen this post by the devs. As a complement: I remember having read some had to use Edge instead of their current Internet browser to pass some steps. On my end, I use Brave and I didn’t met any issue.
If you (or anyone, obviously) still meet any issue, I’d suggest posting in this thread opened by the devs, so that things may be kept clear and convenient for everyone :slightly_smiling_face:

Hello Elfryc,
I tried Firefox and this did not work. But it finally generated the EULA key when I finally used MS Edge. (Enable Pop-up does not seem to be needed FYI). Installing now.
Regards

1 Like

That was the issue as it turned out, now I can play! Thanks a lot!

@reidc39 how did you fix it? I’m getting the same thing

I went into my antivirus (bitdefender) and unblocked it